Unable to Connect to ISRS from VPN

Issue Description

Unable to connect to Uniface (ISRS) when connected to the VPN.

Possible Causes

Before the Uniface app can start, the VPN service is needs to be authenticated with the campus, the U: drive must be mapped to MavDISK, and the Uniface app must be pushed to the computer. This is all done through group policy, which requires VPN to be connected if off campus.

Environment

State-Owned Devices: Equipment provided to university employees and managed by Minnesota State University, Mankato. The steps, tools, or solutions in this article may not work on personal devices due to administrative restrictions or licensing requirements. 

Resolution

You can accelerate the mapping of the U: drive so Uniface will work by forcing Group Policy to update which will remap the drives. Follow these steps:

  1. Click the Start button 
  2. Type gpupdate /force and press enter
  3. A DOS window will open, and group policy will be re-applied. After the DOS box disappears, try starting ISRS (Uniface), or staring file explorer and checking to see if the M: N: and U: drives are now mapped.
  4. Another method is to copy a shortcut for the U: drive to the desktop. After connecting to VPN and ISRS (Uniface) does not start, click on the shortcut to force the U: drive to be opened, and then ISRS (Uniface) will be able to run

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